Folders created during installation

Could someone please explain what is goes on when installing Processing on Windows?
Actually all I did was I downloaded ZIP-file onto an external USB drive and unzipped it onto the same drive.

This resulted in a new folder with file Processing.exe and subfolders core, java, lib, modes and tools which are filled with other non-empty subfolders.

On first running Processing.exe new Processing folder was created on my C://desktop/myDocuments containing subfolders examples, libraries, modes, templates,tools. All these empty.
No “skatchbook” folder was created where sketched are supposed to be stored and no “data” folder where images are supposed to be stored.
This looks confusing.

Questions.

  1. why two separate folders for Processor are created with duplicated subfolders names (modes and tools)?
  2. Could I combine them in a single folder on an external drive (I feel uncomfortable to keep my work on C drive where Windows is installed)
  3. Could I remove the empty folder with the same nemes (modes and tools)?
  4. Where folders Skatchbook and Data needs to be created?
  5. Is it obligatory to store skatched in a folder named Skatchbook? Same question about folder Data for images.
1 Like

Open processing and open File > Preferences:
image

I sometimes use a portable USB stick for projects that I demo and change the sketchbook location.

The preferences.txt location can’t be modified in Preferences.
Make a copy of it if you wish for portability.
I have recompiled the source code to make it portable at one time; it did work but I did need to use this for most of my needs.

Some information here:
https://processing.org/reference/environment/

I would keep the folder “Processing” (can be renamed) and contents as is and copy to your preferred location.
Try opening a few of the “examples” (read only) and “save as”.

:slight_smile:

1 Like

I also noticed that if I run a scatch from the USB drive, a new folder called “Processing” is created in My Documents. If I delete this folder, the scatch would not start sayng that this skatchbook is no longer available. But the second attempt succeeds, yet advised that a library is not available.
So even if a skatch is sitting on an external drive an added library gets onto MyDocuments. Moreover, if Imove the added library folder from MyDocuments onto the external drive, the scatch still looks for it in MyDocuments.
Is there a way to force it not to depend on MyDocuments folder?

thank you, will try your advice and report

For complete portability I started here:


The Processing 3.3.7 that I compiled worked!

This is not for the faint of heart!
This is for the adventurous!

I have not done this in years so you are on your own if you chose to take this path.

:slight_smile:

1 Like

Yes it worked! I changed the path in the Preferences and then observed that it has been changed in preferences.txt. I delited Processing in MyDocuments, run the scketch from USB drive. It asked for the Video library which I added and it added to USB drive.
Yet I understand that if I attempt to run it on another computer? I will have to copy my preferences.txt there.
The problem might be to know where exactly to topy it as on another computer the path shown on the example may not exist. On my computer there is no GLV folder at all. So I have to run Processing first and then replace the preferences.txt

2 Likes

@glv, this is the easy part. After setting your own Sketchbook folder in Preferences, have you checked where Processing 3 stores and updates ‘preferences.txt’ and other text files? If you did, you would see that it stores them on your default Appdata folder.
Now, what is very “interesting” is that even one sets Appdata (in the system environment) to the Sketchbook folder one has set in Preferences and deletes the default Appdata folder (in Windows, this is C:\Users\user\AppData\Roaming), Processing re-creates it and keeps storing there its stuff!!
This what I call programming insanity. Because it’s not a simple mistake or bug of some new S/W. It is a persistent behaviour of a S/W with already 4 major versions. This S/W can do complex and sophisticated things but not simple things with which 99% of the apps have no problem at all. It also ignores and repeats other things that you have instructed it to do or not to do. This is a phsychotic behaviour.

1 Like

Update to my last adventure…

I made a portable Processing 3.3.7 as referenced here:

This evening I made a portable version with Processing 4.1.2 as follows:

I put this on a portable drive and it worked on two different PCs.

The Examples were not on the portable version and I copied them from a Processing 4.1.2 install on PC to the portable drive.

The above created a portable version of Processing 4.1.2 version for me.

Give it a try!

A much simpler option is here at the end of the GitHub issue:

:)