Extending Kinect v2.0 cable

Hi Processing community,

for an installation I am working on at the moment, I need to have one Kinect v2.0 about 10m away from my computer.
Ideally I would like to have the Kinect at 20m, but 10m away could potentially do the job as well.

I have purchased one of these cables (https://www.mwave.com.au/product/alogic-20m-usb-30-active-extension-type-a-to-type-a-cable-mf-ab88755), and it didn’t work. I had no signal coming in my computer from the Kinect.
To be precise, I had a distorted image coming through for about half a second, and that was it.
I have tested the same cable with a USB mouse, and the 20m cable was working fine.

After reading online that some people had issues trying to extend a USB 3.0 signal to more than 15m, I have returned the 20m cable, and swapped for a 10m one, same brand and type just shorter. (https://www.mwave.com.au/product/alogic-10m-usb-30-active-extension-type-a-to-type-a-cable-mf-ab88744), and again no data at all coming from my Kinect.

I can definitely confirm that my Kinect works fine when connected to my computer, and that I have also tried the 10m extension cable with a different Kinect, and still no data whatsoever coming through.

There’s a little note on the extension cable packaging that says that for some applications, it is possible to inject power in the USB cable itself, which in fact has a little power connector on the female end of the cable. Will try that on Monday, however I am not sure what sort of voltage, type of connector or polarity I am supposed to provide, and I couldn’t find any documentation online.

In short, my question I guess is:
Does anybody know and have tested a reliable/robust way to have a Kinect 2.0 10m or 20m away from a computer?


Not sure if this is the problem but from my experince it might be the USB gen. Kinect v2.0 SDK system requirements mentions in a footnote that it wants USB 3 Gen-2. The gen thing is kinda confusing but basically it means it needs a USB 3 capable of 10Gbps not the usual 5Gbps. I have not used an extension cable but I did have a throttling problem on a USB 3 card I bought. But then again sometimes it works fine with normal USB 3 so I can’t say that’s for sure the problem you’re having. Just a note of caution when buying, USB 3.1 can still sometimes 5Gbps. You can do more research on it but basically make sure it says USB 3 (or 3.1) Gen-2. Best of luck!

thank you for the prompt help and for offering advice.

Here my update:
today I have tried to connect the Kinect to a Mac, using the 10m extension cable that I purchased, and it worked straight away.
the Kinect data is coming to the Mac just fine.
That brings me to think that I can narrow down the problem to be due to the USB chipset mounted in the Windows laptop that I intend to use for my installation.

However, using mac unfortunately is not an option, since I need to work on skeleton tracking. I have tried to look up how to do skeleton tracking on mac, but the scenarios seem beyond my programming capabilities…

So, I went back to the Windows 10 machine that ideally I would like to use for this installation, and did some additional testing:
I went on Device Manager and the Kinect appears in the list of devices when it’s plugged in, when using its own cable AND when using the 10m extension cable.
The 10m cable itself appears under Universal Serial Bus controllers; I have updated the drivers, but still nothing.

What it’s not clear to me, is that the Windows 10 machine can see the Kinect fine when plugged in directly (that means that the USB chipset that is mounted is fine). the Windows 10 machine can see the devices in the Device Manager, but it is struggling to see the Kinect when using the 10m extension.

Any idea?