Kinect v2 was working but installed zadig drivers and now won't run on any program

I wanted to run a sketch I had for a v1 using openkinect library but it didnt work and everyone said install the driver on zadig. I did that and it still did not work, but gave no error. so I was like, hey I will just give up and keep using my kinect v2 with the other libraries and on max msp with jitter but now nothing detects the kinect! I tried going back into zadig and changing to winusb drivers for the kinect but it is fuq’t… I run the diagnostic test on the windows sdk and i get green checkmarks all the way til usb 3 and then I get a big red X. I have tried uninstalling/reinstalling all usb drivers on my computer. I am in the middle of a project for school so that is why I am feeling a little more than dumbfounded and stressed about this… anyone have a solution as to how I can revert what I did on zadig???

yesterday I had kinect pv2 library running great with my kinect v2 and also running great in max msp jitter. today I tried to run with openkinect library which needed a driver from zadig, which did not help and ruined any connectivity with any program or processing library. wtf