Exported gradle project not working

Hi there! I exported my processing project via the ‘Export Android Project’ option of the PDE.
Unfortunately, after importing it into android studio the grade build fails.
I am getting the following error:

Unable to find method 'org.gradle.api.internal.TaskInputsInternal.property(Ljava/lang/String;Ljava/lang/Object;)Lorg/gradle/api/tasks/TaskInputs;'.
Possible causes for this unexpected error include:
Gradle's dependency cache may be corrupt (this sometimes occurs after a network connection timeout.)
Re-download dependencies and sync project (requires network)

The state of a Gradle build process (daemon) may be corrupt. Stopping all Gradle daemons may solve this problem.
Stop Gradle build processes (requires restart)

Your project may be using a third-party plugin which is not compatible with the other plugins in the project or the version of Gradle requested by the project.

In the case of corrupt Gradle processes, you can also try closing the IDE and then killing all Java processes.

I already tried downgrading gradle manually via gradle-wrapper.settings as some SO-posts advised. This did not help.

I’m not an expert with Gradle, but have used Android Studio and have had a variety of problems that I sometimes have solved. Do you have other processing export/import projects that work with Android Studio? Maybe try examining all the files and settings from those and if they work, use those settings.
Make sure Android Studio has the API level that the processing export specifies.