Export Application video not working

So I have to play two videos on my sketch and when I run it on Processing it works well, but when I export the application, it doesn’t work at all. Even the program seems not to be running. Grey screen.

I’m on OSX 10.14.6 and Processing 3.5.4. The processing video library is imported. The videos .mov are in the “data” folder.

I think it’s the same issue as: Video library not working for exported application of the sketch and Cannot play the video after exporting the application

Try this Exporting Sketch With Movie Is Blank - #5 by neilcsmith Obviously need to adapt the answer slightly for macOS.

Ok so windows64 will be macOS but what is .dll?

Offhand can’t remember. And the macOS folder name is probably not that. Just find the library install (in your sketchbook folder?) and replicate the location of GStreamer relative to the video library jars in your exported application.

I do have the gstreamer library inside the application contents

Yes, in the wrong place! That folder and the dylib files need to be in another sub-folder. Replicate what you find in the library folder in the sketchbook.

@abatllei having now had a chance to check the library install myself - move the gstreamer-1.0 folder and all the .dylib files into a folder called macosx and try again.

Ok. Where? Inside the application package? Here:


Doesn’t work either :frowning:

No, because you’re not doing what I said. Add a folder called macosx (lower case) in the folder that has video.jar in it (Java?), move the dylibs and the GStreamer folder into it, so all the relative links from the video.jar file are the same.

OK like this?


Keeps like always, sorry if I don’t understand :’(

That’s OK. Looking closer, except the gstreamer-1.0 folder seems to have changed name, and you still have a gstreamer-1.0 folder above? Fix those and see if it works.

Yes! The video is working now! This is the final solution:


Thank you so much @neilcsmith !!!

2 Likes

Great! :smiley: Maybe add a comment on Export sketch bug? Native libraries in different location relative to JARs · Issue #176 · processing/processing4 · GitHub Be good if this issue was looked at.

This doesn’t work for me and I really shouldn’t need to move this stuff myself. It sucks because I am doing so very uncommon work in Processing.

Share the file tree you have, and OS details, etc. or no-one can help you.

And yes, it sucks!

The only reason this is an issue for me is because until recently I had no need for it. I wouldn’t be surprised if it never worked 16 years ago when I first used Processing. I need it to work, not a workaround.

I thank you for wanting to help. I work in the gaming industry. Those “undocumented features” really get to me sometimes. I don’t like seeing it here - grrrrrrrr

It’s only been broken since Video library v2, so only a few years. A workaround is all you’ve got at this point.

The sector you work in reallly isn’t relevant to me. But for context, I maintain the GStreamer bindings that the Video library uses, (and via my company also provide commercial support for them). I don’t like the integration in the Video library - it’s broken in a few ways. But if you want workarounds, I can help you … or not.

This issue has now been completely fixed and no longer requires the work around!

Exporting an application that uses the video library now works in Processing 4.0b8 (released April 22, 2022). Ensure that you have updated the video library to Processing 4 v 2.1

1 Like