Error with Licence agreements

Does any body get this error when running your app? how do you solve this???

You have not accepted the license agreements of the following SDK components:
[Android SDK Build-Tools 26.0.2].
Before building your project, you need to accept the license agreements and complete the installation of the missing components using the Android Studio SDK Manager.
Alternatively, to learn how to transfer the license agreements from one workstation to another, go to

1 Like

have you updated your sdk???
if yes, it seems that you have not checked the license aggrements

How did you install our Android SDK? If you have AS, I bet if you run it it will show you what needs to be updated and any other things that you need to do, like accepting the license. You should be able to do this in the cmd line as well. For this, I will recommend you you do a search on google as I am sure this problem have been seen by many ppl in the Android community.


Hello I have it updated (version 26.1.1) I just checked for updates and is the last version.
how do you check the licence agreements??
I installed android studio, and tried googling the answer, and cant find the answer. I also installed platform 5.0 (Marshmellow) the one that my phone has and get the same error.

then of a lot of research I run into this video

you have to accept the licence agreements via command prompt in sdk/tools, but instead of doing it on the android studio folder do it on processing folder
this is for anyone who faces the same problem.

I had problems doing this.
This worked for me:
What I did was removing the sdk and android mode.
Then installed again and processing would ask to download or locate the sdk.
Then I downloaded it again and it gave me a message to accept the sdk.

If I did the thing from the video I would get:

Exception in thread “main” java.lang.NoClassDefFoundError: javax/xml/bind/annotation/XmlSchema
Caused by: java.lang.ClassNotFoundException: javax.xml.bind.annotation.XmlSchema
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(
at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(
at java.base/java.lang.ClassLoader.loadClass(
… 5 more