[Eclipse] Could not find or load main class at home, but works flawlessly elsewhere

I’m using Eclipse with the Processing library, I made the project on a different computer and tried to move it to my home computer.

When I try to run it, I get the error:

Error: Could not find or load main class Control.Main
Caused by: java.lang.NoClassDefFoundError: processing/core/PApplet

I get the same error trying to run code from a completely separate project using the library, too.

It’s worth noting that jogl-all.jar was corrupt in both the version I had originally and the version I re-downloaded.

Things I’ve tried:

-Re-downloading the library

-Cleaning the project

-Compiling a sketch with Processing’s editor and grabbing the jar files (fixed the jogl-all.jar issue)

-Making sure the classpath is correct

-Copying over the exact .jar files for the library from the original version of the program

-Begging StackOverflow for help

Here’s the code I have for setting up the library:

// Tells the library to use this class as the main class
public static void main(String[] args) {

// Sets the window size and type
public void settings() {

I really need this figured out, as it’s not just for fun that I’m working on this project.


Not enough information to help you.

What is the machine it is working on? Mac? PC? Linux? What version of Eclipse?

How about the machine it isn’t working on?

Did you install the same version of Eclipse, in the same way?

There are several ways to include Processing in an Eclipse project – which instructions did you use to set it up? Did you base your project on the Eclipse Template, or follow a tutorial?

It is possible that your Eclipse installs are not configured in the same way, and/or your project paths point to different places on different computers (user account name, win/mac path structure, install/project location etc.).

Can you create a simple test Eclipse Processing project AT ALL on your home computer? That is, is it just this one project, or is it the whole environment that is not configured correctly?