Can't run P5.js "This item needs to be recompiled for Java 8"

Hi all,
I don’t know exactly what happened, but starting today “P5.js Mode” is missing in my Processing.
I tried to re-add it, but after downloading it gives the above mentioned message “This item needs to be recompiled for Java 8”
Googling for it gives No results found for “This item needs to be recompiled for Java 8” .
The console also shows “err is java.lang.UnsupportedClassVersionError: processing/mode/p5js/p5jsMode has been compiled by a more recent version of the Java Runtime (class file version 61.0), this version of the Java Runtime only recognizes class file versions up to 52.0”

Any idea as to what might have happened?
I’m running 3.5.4 for Mac

Thanks in advance :slight_smile:

1 Like

PS: by the way, I know it works fine on Processing 4. It’s just that it worked as well in 3.5.4 until now.

Same thing happened to me yesterday. Have you found a solution?

1 Like

Unfortunately no. Not even conversations on the topic. For now it appears P5.js is limited to Processing 4, so unavailable for older OSs…

Same here, suddenly I cannot use and install p5.js anymore within Processing.
And same error “This item needs to be recompiled for Java 8”
I normally use p5.js with VS Code or online but still it is strange this isn’t working anymore.

Sorry, p5jsMode now requires Processing 4 (due to changes in newer Java releases). Processing 3.5.4 is now over two years old; please upgrade!

For Processing 3, grab p5js Mode v1.3.1 from the link below:

Extract the compressed file into your “Sketchbook location”/modes subfolder.

Before running the PDE, open the file “” inside the extracted subfolder “p5jsMode”.

Change the entry “name=p5.js Mode” to something else like “name=p5.js Mode P3”.

PDE’s updater won’t touch the legacy p5js mode after the renaming.

1 Like

I wish I could give up 3.5.4, but I’m being hit by problems that may be caused by the beta of 4, so I seem to need it to trouble-shoot…

Many thanks for Processing, it’s great!