Can't run emulator make_ext4fs_from_dir

emulator -avd processing-phone
error: make_ext4fs_from_dir: open: Permission denied

I have the processing-phone under avd in my documents processing folder
and the sdk is installed, I also reinstalled

I can’t get emulator to run

It exists processing with:

Emulator process exited with status -1073741819
EmultorController: Emulator never booted. NOT_RUNNING
Error while starting the emulator. (NOT_RUNNING)

Generally, you‘d want to add the OS you‘re having the problem on, if it‘s related to the System.

As for your problem, i assume you use Ubuntu. You probably have no permission to access the directory.

Apparently this can be fixed by granting permission to either the User or the file.
The User :

sudo chmod a+rwx path/to/file

The File :

sudo chmod -R a+rwx path/to/file

Thanks, but I am running Windows 10 64-bit, and I already took full control of all folders such as documents, .android, etc.

Oh… are you sure it‘s not „Access denied“ then? Did you also open the Cmd with Administrator rights? Maybe that could help, before we start doing unneccessary difficult things :sweat_smile: .

Edit : Another reason might be that some related things already running and thus access is denied… maybe try restarting your Computer and only run the cmd command.

yeah I always run as cmd as admin. I looked at launching the emulator outside of processing and google led me to cd to the emulator dir which is some like C:\Users\myname\Documents\Processing\android\sdk\emulator and then I ran avd list to confirm that the proccessing-phone image was picked up and it is and when I try to run with emulator -avd processing-phone it exits with permission denied I checked .android and I have full control also in Documents my sdk and avd folders are in the processing documents folder. I don’t know what to check I also checked the driver thing in device manager and I do have the driver so I am lost which is why I came here :upside_down_face:

Edit: Sure, I’ll do the old turn it off and on again

Please tell me if it worked then^^ I know it sounds like a cliché, but that‘s still the easiest way to get things to work sometimes :sweat_smile:

got the bad boy running seems it needed processing-phone.ini which wasn’t created when I installed it from processing, I installed the emulator from android studio and …BAM it worked! Thanks for the help, I appreciate it! :grinning:

Glad it worked :wink: .