Adb not working, looking for ant

I love these cryptic names for packages related to android. I use Android Studio and Processing. Android Studio started misbehaving about the same time that google started bugging me to upgrade. I finally gave in and upgraded and its been a nightmare since. Nothing works right, or it will kinda work and then it suggests more downloads and my internet connection is very slow.

The problem for Processing Android Mode is that it uses adb to connect to the device and upload the compiled apk. If I try to use Processing in Android Mode to run a sketch on device, it now fails and says its looking for ant and something about some xml files.

I can upload using a terminal in the adb directory if I copy paste an apk there, but that’s just the wrong way to do things. Is there something I can do to fix this so Processing is happy again?


ant? - P5 uses gradle since a lot of time…What version of P5 android mode are you using? What version for AS?

I fixed it I think. I renamed the sdk folder and then started Processing in android mode. It of course couldn’t find the sdk and I selected download sdk automatically option. This time it put the sdk somewhere different than where AS wants it. I tried any old sketch and it uploaded fine.

Yup, its working right. @akenaton got me thinking though, why do all my exported android projects use ant? Its a pain now because Android Studio is updated and wont even properly import older projects. It must use Gradle and it must compile using API 21 or above… Oh well, I’ll adapt. The first one was a bear.