Why cant I run a camera at 60FPS?


I have this application that requires fast video processing, there are items in motion on a belt.
So I got a camera that goes up to 120 FPS. It also does 30 and 60 FPS>

I am able to run it well at 30FPS or less. But I get no video in any resolution as soon as I try to run at 60 or more FPS.

I wont attach the code, since I am using the Examples- Video - Getting Started with Capture.
I just change the index no in the capture line in setup for various cameras.

I tried to run the sketch at 60FPS but that did not help.

Please help, Thank you


1 Like

Hi, i really don’t know what could it be, but when i was reading about the kinect it said that because of the hardware itself, the max framerate is 30 fos, but i don’t know if is the same issue with the camera.

My camera is capable of 60 FPS, I tried it on other apps…
I wonder who wrote the video library. I bet he could fix it.

I wonder if there is a library for camera settings. Exposure, hue, white balance…

Thanks for thinking of it