Video capture on macOS Catalina not working

Trying to run any sketch that uses the processing.video.*; library with a Capture object fails to run. Below is the error that prints.

I’m pretty devastated :disappointed:. I’m teaching a class right now and have been building towards camera input for a while. Was ready to wow the students and ran into this.

Steps to reproduce:

  1. Open the Examples… GettingStartedCapture sketch and run.

I’m running macOS Catalina 10.15.3, and Processing 3.5.4.

Any suggestings?

2020-03-22 21:32:29.541 java[8846:93043] -[__NSArray0 addObjectsFromArray:]: unrecognized selector sent to instance 0x7fff84fa4e30
2020-03-22 21:32:29.541 java[8846:93043] *** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: ‘-[__NSArray0 addObjectsFromArray:]: unrecognized selector sent to instance 0x7fff84fa4e30’
*** First throw call stack:
(
0 CoreFoundation 0x00007fff2c3cc8ab __exceptionPreprocess + 250
1 libobjc.A.dylib 0x00007fff62686805 objc_exception_throw + 48
2 CoreFoundation 0x00007fff2c44bb61 -[NSObject(NSObject) __retain_OA] + 0
3 CoreFoundation 0x00007fff2c330adf forwarding + 1427
4 CoreFoundation 0x00007fff2c3304b8 _CF_forwarding_prep_0 + 120
5 libgstapplemedia.so 0x0000000129d2b2bc libgstapplemedia.so + 58044
6 jna5046322432209832617.tmp 0x00000001260f1134 ffi_call_unix64 + 76
7 ??? 0x0000700004845278 0x0 + 123145378091640
)
libc++abi.dylib: terminating with uncaught exception of type NSException
Could not run the sketch (Target VM failed to initialize).
For more information, read revisions.txt and Help → Troubleshooting.

1 Like

Turns out this fix worked for me:

1 Like

This video shows how to fix the problem. Processing Video Capture Issue (MAC) Solved - YouTube