Unique icon while exporting signed pakage[Android]

I got this error while exporting my package:[Image below]

process
I know this error but don’t know how to solve it. Please tell me step-by-step how to do this!:no_mouth::thinking::thinking:

@manhnt===
full set means: you have to “decline” your icon for ldpi, mdpi, hdpi, Xhdpi, xxhdpi, xxxhdpi knowing that mdpi is the “medium” value, that is 160dpi, and that as for now you can forget ldpi, so = 160, 240, 320 , 480, 640dpi; you create them, go to the icons folder and put your icons instead of the “standard” processing ones, but using their names…

Thanks for your answer, but it doesn’t still work. In my case, I created a root folder in my sketch one called “icons”

Then, I created ldpi, mdpi, Xhdpi,… folder and put in it an icon for each size supported
detail
Anything went wrong?

Check these links:

https://forum.processing.org/two/discussion/comment/69024/#Comment_69024

https://forum.processing.org/two/discussion/21061/how-can-i-set-game-icon-which-is-app-icon

https://forum.processing.org/two/discussion/comment/106489/#Comment_106489

https://forum.processing.org/two/discussion/comment/73420/#Comment_73420

Kf

@manhnt===

as i said: put the icons inside the icons folder from P5.

@akenaton===
It didn’t work as well. I will tell you more detail about my problem. Please tell me how to do that(I’m a processing beginner)
Here is my target Sketch folder(SmartSnakesCombine)


As you can see, the right is “icons” folder-the folder you want me to create.
In the “icons” file is icons supporting different size!
I listed them as: ldpi,hdpi,mdpi,xhdpi,xxhdpi and xxxhdpi
All of them are .png format
My Androidmanifiest file:

`<?xml version="1.0" encoding="UTF-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android" android:versionCode="1" android:versionName="1.0" package="com.darkyprod.smartsnakes">
    <uses-sdk android:minSdkVersion="17" android:targetSdkVersion="26"/>
    <application android:icon="@drawable/icon" android:label="">
        <activity android:name=".MainActivity" android:theme="@style/Theme.AppCompat.Light.NoActionBar.FullScreen">
            <intent-filter>
                <action android:name="android.intent.action.MAIN"/>
                <category android:name="android.intent.category.LAUNCHER"/>
            </intent-filter>
        </activity>
    </application>
</manifest>
`

:thinking::thinking:

@manhnt===

i have not told you to create an icon folder ! - i have told you to go to the icon folder created by P5 IN THE MODE FOLDER /ANDROID (make a copy from this icons folder) with the default icons: then you put your icons with the Same name than the default icons, that s all…

Sorry for my misunderstanding. Now , it work perfectly::smiling_face_with_three_hearts::no_mouth:

Hi!
I’m new in processing and trying to create live wallpaper for android using android mode. I’m stuck with this unique icon creation step. I just can’t get it work, i don’t know where is the thing that I’m missing. Could someone create a very easy to follow step by step directions for dummies how this can be done?

Any help would be really welcome!

@TurboUrpo ===

what have you tried till now … i think i have alreay given precise step by step…

I followed these instructions https://forum.processing.org/two/discussion/comment/69024/#Comment_69024

I’m not 100% sure in which folder I have to put those icon files and how to name those. Just to make sure, do I need to export android project first and is the icon location in one of those folders?

Also I tried with this, but I don’t understand that fully, what copy from where and do I left the default icons or delete them and name my own icons as the default ones.

@TurboUrpo Akenaton instructions refers to the mode folder which is located in your sketchbook. The sketchbook location is defined in the PDE under the following menu entry: File >> Preferences…

If you visit this location, you will find multiple folders related to Processing: For example, Libraries folder contains all the libraries installed using the Contribution manager. Likewise, the Modes folder contains all the installed modes. Inside this folder you will find the Android folder that akenaton is referring to. I believe the instructions he is providing there is for publishing applications. In my experience and while doing testing and releasing apps manually by generating the unsigned apk, I will just place the icon files within my sketch folder (Ctrl+K when running the PDE on Windows). Make sure these files have the same name and you have generated all the required resolutions as described here under the " Setting custom icons" heading.

Kf

Thanks.

But I don’t still understand :smiley: So the sketch folder contains android and code folders, androidmanifest and the pde file. I just put the icon files here? And how can I name all the icon files as the same filename?

I know I’m dumb :smiley:

Sorry, I didn’t tag you (I pressed the wrong reply) .

@akenaton @kfrajer I’m still trying to figure this out, what I’m missing. So I put my icons in the modes/AndroidMode/icons folder and replaced the default ones, and named my icons as icon-36, icon-48…icon-192. When I open my pde file it creates code folder and AndroidManifest xml file, and when I export android project, it creates android folder and inside it it creates app and gradle folders and some other files. In android/app/src/main/res/ there is drawable… drawable-xxxhdpi folders and it loads my icons automatically in these folders. But I still can’t export the signed package, I don’t know why.

Does it think that the files are still default ones because they are named as those were? I tried also name my icons differently, but then it doesn’t even load those files in the android/app/src/main/res/drawable thing.

What about those AndroidManifest files, one is in the sketch folder with the pde file and android and code folders. The other one is in the android/app/src/main/ with assets, java and res folders. Should I do something with those? I have changed my applications name in the first AndroidManifest file @ package=“myappname”>

So I’m completely lost with this and just hammering my head against a f**king concrete wall with a force of million unicorns. :smiley

@TurboUrpo

Ok, let me ask you one question. When you do testing and you run your app in your emulator or device, did you check that the icon changed after you placed the icon folder in the root folder of your sketch and run the sketch? In other words and taking you step by step, you have your sketch (a pde file). You press ctrl+k to open the sketch folder and you added the icon files (with proper names: icon-36, icon-48…icon-192) there. Then you run your sketch and it is launched on your device. You can exit this app by pressing the back button. Next you need to look for this app in your device and check the icon. Please let me know if you have done this. No need to use a complicated app and I encourage you to use a simple hello world instead. After you confirm this, we can focus in the signed apk but I have to say my experience is limited when it comes to signed apps.

Please note that there is no need to modify the icons in the mode/Android folder and there is no need to export the project.

Kf

@TurboUrpo , @kfrajer ===

  • I have answered to the question which was tagged (exporting signed apk)
  • If the question is how to export to AS with other icons than default, the solution is very simple: you import the result into AS and change the icons
  • if you change the name of the icons you have to change it into the Manifest too (launcher) but why that???
  • if you want only to change the icon (not signed apk but debug mode) you can also apply my solution
  • as you are saying that you cannot export to signed apk what is the error which is returned???- Can you export (to signed…) with the default icons???

@kfrajer @akenaton

At first, thank you so much for the advice and patience.

I figured this out and I’m now able to export the signed package. The solution was simply to put those own icon files at the sketch folder and name those as icon-36, icon-48…icon-192. And this solution and advice was already given several times in this conversation and also some others. The reason why I still asked for advice for this problem was, that I have tried multiple times the given solution, and it didn’t work. I don’t know why it didn’t, but now it works so thats cool. Problem solved.

Sorry for these (stupid) questions, now I can stop hammering my head against a concrete wall with a force of million unicorns, and use the force to nicely build my stuff. Once again, thank you!