Tobii 4C library - Processing disappeared

The link seems to be down and I cannot reach Mr. Esteves. First it appeared in the library list of processing but it couldn’t been loaded. Now it has completely disappeared.

Do you have an alternate download link or access to the library you are willing to share with me?

Thanks in advance, Johan

1 Like

Welcome to the forum!
Have you tried manually installing the source on his github?

1 Like

Hello Tony, yes, if you click on the link for the gazetrack library that you need to install manually you (at least I do) get a 404 page not found. The email address of the author doesn’t seem to exist anymore. Please help me. Best regards, Johan

The link in the README is dead, but i think the pertinent code is all there in the repo (albeit, not labeled the same as the instructions). It might require some library-wrangling and trial-and-error thought :grimacing:

I’m specifically looking at the .jars under gazetrack/GazeTrack/lib/

So far a lot of trial and an even amount of errors. Is there a reason why the library has been removed? Has someone a backup? Am I the only one wanting to explore the eye gaze function with processing?

It might not have been removed - but if Esteves has been the only one maintaining it, it might not get updated that regularly. Thats the unfortunate nature of open-source. A project might die or disappear on the whim of its creator.

The other reason; perhaps there are much more accessible eye-tracking libraries out there, written in more popular languages (like javascript or python).

I think I have a version of the gazetrack library kicking about, might not be the latest version, however I’m away away from my development rig currently.
If you can flick me a message tomorrow I’ll have a dig around for you.
I made agame using the tobii eyetracker that never quite got finished. Fun toy though.

Upon closer reading of your title I see that you want 4C, I was using the eyeX, so I don’t think the library i have can be of any use to you.


Thanks for checking Tribblesontoast. The library for the EyeX seems to be still in the list, it is the one for the 4C that was available and suddenly disappeared. Perhaps someone downloaded it in the past and can make it available to me?

Hi Toni, I found this on the old forum:

How can I get in contact to the members of the old forum. Sorry for insisting but the result could be useful for other users.

I prefer the flavour of Processing over JavaScript and Python. It is of course my personal opinion but I hope you agree on that :wink:

@jeremydouglass might have something to say. As for Esteves, have you tried this other email?

It looks like Augusto literally committed to the GazeTrack repo yesterday – there are five commits in the last two days. If you need an old release instead, the 2014 release is on releases tab for download, and if it doesn’t work, opening an issue on the repo seems the best way to contact him and request a new release.

See also the wayback archive of that old linked page:


The Wayback Machine has not archived that URL.

Thanks Jeremy for pointing back to the repo. The links in it are active now. I downloaded them and I’ll check it out.

Good news. It works now …kind of…
Thanks to jeremydouglass and tony for pointing out there was an update of the GitHub repo:

the broken link has been replaced by
It is important you import the library called UDP (in the menu Sketch > import library > add library…)
Examples Basic and Dwell work at this point.
I haven’t got the other examples to work yet.
Thanks of coarse to the author Mr. Esteves.