[SOLVED] P2D/P3D sketches won't start on fresh Ubuntu 18.04 installation

What is glxinfo?
I tried typing that into the terminal, it spewed out a large amount of display and OpenGL related information, in which I don’t see anything particularly interesting.

Dang! So it’s not just interaction between Processing and the driver then. Something about your system / GPU too.

You could have a try at setting PJOGL.profile values from 1 to 4 - see https://github.com/processing/processing/wiki/Advanced-OpenGL

You haven’t installed anything that would have installed libjogl from Ubuntu packages have you?

It’s possible different drivers trigger slightly different font rendering.

Tried setting PJOGL.profile to different values and running the sketch - 0,1,2,3,4,5,9999… Nothing changed at all, same error message each time.

(to clarify, test sketch I’m using is nothing more than size(500,500,P2D); and rect(mouseX,mouseY,50,50); )

In settings() not setup()? If so, I’m fresh out of other ideas. I recommend posting an issue on GitHub.

Oh, I tried it in setup(). However, I just retried it in settings() too, but still no effect.
Although, setting it to 1 gives a different error:


com.jogamp.opengl.GLException: Not a GL2ES2 implementation
	at jogamp.opengl.es1.GLES1Impl.getGL2ES2(GLES1Impl.java:4959)
	at processing.opengl.PJOGL.getGL(PJOGL.java:260)
	at processing.opengl.PSurfaceJOGL$DrawListener.init(PSurfaceJOGL.java:888)
	at jogamp.opengl.GLDrawableHelper.init(GLDrawableHelper.java:644)
	at jogamp.opengl.GLDrawableHelper.init(GLDrawableHelper.java:667)
	at jogamp.opengl.GLAutoDrawableBase$1.run(GLAutoDrawableBase.java:431)
	at jogamp.opengl.GLDrawableHelper.invokeGLImpl(GLDrawableHelper.java:1291)
	at jogamp.opengl.GLDrawableHelper.invokeGL(GLDrawableHelper.java:1147)
	at com.jogamp.newt.opengl.GLWindow.display(GLWindow.java:759)
	at com.jogamp.opengl.util.AWTAnimatorImpl.display(AWTAnimatorImpl.java:81)
	at com.jogamp.opengl.util.AnimatorBase.display(AnimatorBase.java:452)
	at com.jogamp.opengl.util.FPSAnimator$MainTask.run(FPSAnimator.java:178)
	at java.util.TimerThread.mainLoop(Timer.java:555)
	at java.util.TimerThread.run(Timer.java:505)

Maybe this is relevant too actually? https://github.com/processing/processing/issues/5476

You could try 3.3.6.

Can’t find a Processing 3.3.6 Linux 64bit installer anywhere. Do you happen to have a copy of it?

It works! Using Processing 3.3.6 works, while 3.4 doesn’t.
I guess I have that same problem as the one mentioned in that thread you linked here. And, since developers people guys are already aware of this, I guess I shouldn’t do anything else, besides using this older version and checking out future releases if they work or not.

Thanks!

I would add a comment on that issue with details of your setup. Glad it works!

tux@tux-PC-2163 ~ $ glxinfo
name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:
    GLX_ARB_context_flush_cont

What you want to see is direct rendering: Yes, the other stuff tells you about the opengl capabilities of your card.

Yes, it does say “yes” there. And other stuff seems… Fine?
Should I post the whole output here? (especially considering that the issue is pretty much solved for me and I feel like continuing this topic is pointless)

You could add the output of your glxinfo to the GitHub issue. There is one there already. Might help narrowing down the problem. The direct rendering line is not relevant to this issue, but the rest might be.

Oh, allright. I guess it could help(not in scrolling the page, that is :D).

Edit: Posted a pastebin link to it there. Nevermind about scrolling :D.

:+1: Getting bugs fixed is a two way thing! :smile:

@neilcsmith I just send a PR to revert the JOGL change. Thanks for digging.

1 Like

@gohai - now downloading 3.3.6 to check mine wasn’t one of the AMD GPU systems it fixed! :laughing:

I see the JOGL bugzilla is down again! Where are things at with LWJGL these days from a Processing perspective?

@gohai aaarghh! So, bit of help digging, and broken my own system. :roll_eyes:

@Architector_4 given that the proposed fix (reversion) now breaks my system, can I ask if you could possibly try the following code in Processing 3.4 on your system and see if it works? The lack of bc profiles in your first error message is intriguing me.

void settings() {
  System.setProperty("jogl.disable.openglcore", "true");
  size(100, 100, P3D);
}

void setup() {
  PGraphicsOpenGL pg = (PGraphicsOpenGL)g;
  println(PGraphicsOpenGL.OPENGL_VENDOR);
  println(PGraphicsOpenGL.OPENGL_RENDERER);
  println(PGraphicsOpenGL.OPENGL_VERSION);
  println(PGraphicsOpenGL.GLSL_VERSION);
}

void draw() {
  ellipse(width/2,height/2,width,height);
}

1 Like

It works on my machine in 3.4! I get a boring window with a 100x100 circle in it!

It also prints this:

X.Org
AMD MULLINS (DRM 3.23.0, 4.15.0-34-generic, LLVM 8.0.0)
4.5 (Compatibility Profile) Mesa 18.3.0-devel - padoka PPA
4.50

I’ll still stick to 3.3.6 myself though until next version or some fix comes out.