Run Processing with SSH command issue


I’m still working on my project, and I’d like to start several sketch (only one at a time) by distance (from a command laptop to my video laptop)
So I managed to make it with SSH. I installed a small wifi rooter.
My 2 laptops are connected to this rooter.
And I run my command :

ssh user@ipadress 'DISPLAY=:0 /home/jokoko/processing-4.0.1/processing-java --sketch=/my/sketch --output=/tmp/processing/raes --force --run'

But all the time it only work once. After that, when I run my second command to stop the sketch :

ssh user@ipadress 'killall java'

It kill the process and so my sketch shut down, but I cannot run processing anymore, neither via SSH nor manually from my video laptop, until I disconnect from my wifi (or ethernet, I tried both) connection…

My both laptops are running with ubuntu studio 22.04 (KDE plasma), and I’m using processing 4.0.1 (I opened a topic a few days ago because I had a weird bug of ArrayOutOfBound that doesn’t allow me to use processing 4.2 anymore, but it seems no one has the answer… the topic )

thank you