Processing error with display attached to MacBook

Processing has stopped working when i have a high res monitor attached to my M1 macbook.

This only occurs when using a USB C out, HDMI works fine at 3840 x 2160
Running USB C out to a 3840 x 2160 display works fine also
The USB C is outputting and i get the following error when attached to a 3840 x 2400 display

It was running fine, then just started throwing the following error. If anyone can shed some light on what might be happening?

A fatal error has been detected by the Java Runtime Environment:

SIGILL (0x4) at pc=0x00007ff808cb77ba, pid=3172, tid=7939

JRE version: OpenJDK Runtime Environment Temurin-17.0.2+8 (17.0.2+8) (build 17.0.2+8)

Java VM: OpenJDK 64-Bit Server VM Temurin-17.0.2+8 (17.0.2+8, mixed mode, sharing, tiered, compressed oops, compressed class ptrs, g1 gc, bsd-amd64)

Problematic frame:

C [CoreFoundation+0x1b77ba] CFEqual.cold.1+0xe

No core dump will be written. Core dumps have been disabled. To enable core dumping, try “ulimit -c unlimited” before starting Java again

An error report file with more information is saved as:


If you would like to submit a bug report, please visit:

Issues · adoptium/adoptium-support · GitHub

The crash happened outside the Java Virtual Machine in native code.

See problematic frame for where to report the bug.

Could not run the sketch (Target VM failed to initialize).
For more information, read Help → Troubleshooting.

sorry, no solution here but does it fail if the display is attached before launching processing? had this issue few times, but i think only when connected/disconnected while processing is working

Fails if the display is attached before launching processing or running the sketch, runs fine if attaching the display after the sketch is running.

Strangely the issue doesn’t occur if i dont declare P2D or P3D, so it will run P2D if not declared, but in this case i need P3D.

Have tried both the arm and 64bit intel versions, havent tried processing 3 yet.

Ok, little update on this. The issue seems to be when the display resolution is not in a 16:9 or 4:3 format. So any 16:10 (ie wuxga) or custom ratios wont run if declaring P2D or P3D

Is anyone on a PC or intel mac able to reproduce this?

Also happening on the intel P3 release.

EDIT: got a hold of a WUXGA monitor that it works fine on. Seems datapath might be the culprit. Gonna step back for a bit. If anyone else has any thoughts please share.