Processing 4 crash issue

please format code with </> button * homework policy * asking questions

I used Processing 4 in android mode to develop application.

I stopped for some time, as at last before I stopped. I application compiling and loading in n the phone.
Now I trying to resume work, I am getting error nullpointer error. Can’t tell where the issue coming from. See the attached screen shot

There it is in the error. You use length on the list that is null (uninitialized?).

I tried to review the code once more.
The only arraylist initialized was though has been commented out but I still have that null pointer.

I am forced to reinstall Processing IDE.
Now it will compiled and install on the phone with success report but I get another report saying “waiting for debugger”
See newly attached screenshot

As for latest issue.
I solved it by uncheck “wait for debug” in my phone settings.

Everything working Okay now.

For curiosity, why was the first error report until I had a clean installation of Processing IDE?