MPU6050 accelerometer double integration doesn't work

Hi everyone!

Is there anyone here who has experience in integrating the MPU6050 twice to get the displacement? I have worked on it for months, but without any result. After reading in different forums that a very small iteration time was needed when integrating an accelerometer twice, I decided to work on my iteration time and managed to get an iteration time of 3 ms with the help of people from this forum. However, even this did not give me any satisfying result. The way I integrate twice is as following:

acceleration reading => low-pass filter => high-pass filter => integration => high-pass filter => integration

I have also tried all sorts of combinations and cut-off frequencies, with bias compensations, or with only one high-pass filter, without low-pass filter, you name it, but the results I get are far from being satisfying…

I hope someone has the answer!

Thanks in advance!


Hi, do you have your raw data from the sensor to download?

1 Like

Thanks for your reply @jb4x! Yes I do! Here is the we-transfer link of the file. The movement I am making here is:

sensor is on the table => sensor is taken up in the z-direction => stays there for a few seconds => sensor is brought back to the table.

It is not really raw data actually, it is data in units of m/s², but it is not manipulated.