Movie Maker ffmpeg.exe not found

As I work a lot with Nodebox I checked out Processing.
Tried some examples but can’t get the Movie Maker to work to render my projects.
I’m on Win10.
Tried the old Processing version (3.5) and tried to use video export but couldn’t get ffmpeg installed.
Tried now the new beta version with the Movie Maker but I get an Error code that it can’t find the ffmpeg.exe but it’s in the folder the error messages says it’s not. (default from installation / win10).

Hope somebody has some tips.


Movie Maker works with Processing 3.5.4 on my W10 PC.

Processing 4.0b1 gives me this error:


I have the same error just different (install) path.

Same problem with me (Windows 7) …

I checked, the file is in the right folder…

(quite a pitty because appart from that, Processing 4 works great)

Has anyone experiencing this problem considered opening a bug report on the Processing4 repo?

I don’t see any open issues for MovieMaker or ffmpeg – and the places in the build that reference ffmpeg.exe are quite limited, so this shouldn’t (?) be too hard to track down:

1 Like

could you add the .ffmpeg.exe directly to the directory its complaining about by downloading from sources on here…

Is it possible that the ffmpeg that comes with Processing is a debug version? Or why the size difference?

~ $ ls -sh /bin/ffmpeg
292K /bin/ffmpeg*
~ $ ls -sh bin/processing-4.0b1/tools/MovieMaker/tool/ffmpeg 
74M bin/processing-4.0b1/tools/MovieMaker/tool/ffmpeg*

Sorry for not answering to the original question, but since the discussion is about ffmpeg… I thought my question is not worth its own topic :slight_smile:

1 Like


It is already in the directory from the Processing 4 beta install and the same file size (to the byte) of one of the Windows builds at the site you referenced.

Yeah, same file. I switched anyways but the result is the same.

Following your suggestion, I posted a bug report : Movie Maker can't find ffmpeg.exe · Issue #268 · processing/processing4 · GitHub


Ben fry answered on github : The workaround is to put Processing in a folder that doesn’t have spaces in its name ( Program Files (x86) is causing the problem here). But it should also be fixable.



@Jean-no Thanks for reporting this!

Works now!


1 Like