Integrating Processing to Sublime

I was trying to use processing-java to open a processing sketch. I am running windows 10 and processing 3.3.7. I right clicked and used the open with menu to select the processing-java. Am I using processing-java correctly, and, if so, what could be going wrong?

There used to be a wiki explaining how to use processing-java but I cannot find it. The closest I got was this one: https://github.com/processing/processing/wiki/Command-Line

Nevertheless, you use processing-java from the command line. If you open a command window (or a terminal in Linux/Mac), then you type

processing-java --help

If you have the path setup properly for Processing, you should get the menu and instructions how to use it. Also I add these previous posts:

https://forum.processing.org/two/discussion/20681/running-processing-sketch-from-command-line-on-windows
https://forum.processing.org/two/discussion/23924/handling-command-line-arguments-in-a-sketch

Kf

1 Like

By console do you mean command prompt, or something else?

Yes, a console is a command prompt. What are you trying to do? Maybe you are trying to fire the Processing IDE? You need to click on the processing.exe instead. The second executable, processing-java is to run/build/export processing applications via the command prompt. Just to add, the IDE does all these for you if needed.

Kf

I am trying to use sublime text instead of the Processing IDE. I am using a school computer, and command prompt is disabled, so that might have something to do with it not working.

Consider changing the title of your post. You should add Integrating Processing to Sublime. I have not done this before. Maybe somebody in the comunity may know. You should consider posting in stackoverflow as well, if you havent done so. Please, consider cross-posting your posts.

Kf

I’ll do that. Thank you for your help.

@Quillbert1 Have you tried installing Processing from Sublime’s Package Installer?

Yes, I did that, but it still is not working.

Can you describe step by step how you trying to use sublime with processing ?

Here some importants points to follow :

  • Your build system on sublime must be define as Processing. Go to Tool > Build System > processing on sublime
  • If you start a sketch from scratch remeber your “file.pde” must be in a folder with the same name “file”. It will not working if not.
  • Have you a setted any shortcut like ctrl+R. Have your tried to build your sketch with tool > build ?
1 Like

I checked the build system, and it is processing.
The folder has the same name as the sketch.
I haven’t changed any shortcuts. I have used tool > build.
Whenever I try to build, I get an error saying " ‘wmic’ is not recognized as an internal or external command,
operable program or batch file."

After a (really) quick research it seems you haven’t setted your path variable environment.

Here a quick step by step from the processing for sublime package :

You will need to set your PATH environment variable to where your processing application is located:

Open the “Advanced System Settings” by running sysdm.cpl
In the “System Properties” window, click on the Advanced tab.
In the “Advanced” section, click the Environment Variables button.
Edit the “Path” variable. Append the processing path (e.g. ;C:\Program Files\Processing-2.0b6) to the variable value. Each entry is separated with a semicolon.

Reference : https://github.com/b-g/processing-sublime/blob/master/README.md

Hope this will help

I tried doing that, but it didn’t seem to help. Do you know which specific file I need to add the path to? Is it the folder or the processing-java file?

If you open a command prompt window and type processing-java, what do you get?

The proper way to setup the PATH in Windows is via System Environmental Variables which you should be able to access via Cortana. You need to introduce the Path to the processing folder containing the executable. To clarify, there are two executables in that location: Processing.exe and Processing-java.exe. The first one is the PDE and the second one is to build and run your pde from the command line, which I am guessing sublime needs (I dont use sublime).

Every time you change the environmental variables, you need to make sure you close all the dialogs and then you need to restart any command window for the changes to take effect. You know you have setup the path properly if you type processing-java in a command window and you get the help menu from that command.

If you need more help about setting up the path, you can do a google search as I am sure some people have devoted good efforts to demonstrate this step by step.

Kf

I can’t type anything into command prompt, because I am using a school computer and the school has disabled command prompt. This might be the problem.

@Quillbert1 that’s unfortunate, you may need to contact whoever is in charge of those computers at your school see what they will allow you to install or not.

You might be able to install Sublime on a USB drive and run it from there?

Sublime works, it just can’t build. Thanks for your help.