How to disable VSync in Processing P3D

Im not sure why this has to be so complicated but I cant find a way to disable vsync in processing.
Specifically p3d.
Any help?

You can set frameRate(1000); and then write it to the screen to see what you get.

If it’s still locked at 60 fps or whatever your monitor is using, then you might need to look at your video driver settings outside of Processing to see if they are locking all applications to the frame rate.

This code bounces around the high 900s for me on linux with nVidia after I disable “sync to vblank” in the nVidia driver settings app.

void setup() {
  size( 600, 400, P3D );

void draw() {
  background( 0 );
  text( nf( frameRate, 0, 2 ), 300, 200 );
1 Like