How to add Processing shortcut to launch panel

I have tried several different ways to add a shortcut for the Processing app to the launch panel but it doesn’t want to go. Does anyone know how to get it in there? I’ve tried dragging it, tried adding it by the panel editor…

Hi @ddownn Just to be sure, what version of processing and Pi are you running? i’m assuming you already tried something like this this procedure from

Right click anywhere on the panel.

Click “Add / Remove Panel Items”.

Click “Add”.

Find “Application Launch Bar” in the list.

Select it and click “Add”. It should appear on the very end.

Click “Up” until it is above “Minimize All Windows” but below the “Spacer” above it.

Now click “Preferences”. It should show 2 columns, the 1st one containing displayed apps and the second containing the remaining ones.

Select the apps you want to add and hit “Add”.

1 Like

The Pi has:

Linux raspberrypi 4.14.34-v7+ #1110 SMP Mon Apr 16 15:18:51 BST 2018 armv7l GNU/Linux

… with Processing version 3.3.7

According to the “Add / Remove Panel Items” dialog, it seems like Processing is being added, and can be moved Up and Down in the list. But it never shows up in the Launch Bar.

Adding and moving other applications works as expected.

I add Processing, and move up in the list:

I was going to upload a series of screen shots but I can only post 1. But at any rate, it looks just like it should be working but Processing is the only app I have tried that doesn’t get added to the Launch Bar.

UPDATE: It was a NOOBS install.

But anyway, I created a new installation of Raspbian and now I’m not having this problem anymore.

1 Like

sounds like great news! I hate the fact that sometimes we have to reinstall the OS to get simple function to work.

So Processing came with the Raspberry Pi? Sorry, not very familiar with these devices.

No… I downloaded the Raspbian image, then installed Processing separately. I guess there are some distributions of Raspbian that include Processing but I didn’t use one of those.

I installed Raspbian, Kodi, and something else at the same time, and I figured out that all I was going to use was Raspbian and I was tired of the multiple boot screen. So I deleted the other two OS’s, but then I couldn’t find a way to reclaim the 15GB they were using on the card, so I decided to start from scratch on a fresh install.

After that, Processing worked normally. I can’t remember what version of Raspbian I started out with, but it was just a few months ago. Maybe there was some glitch in the OS or in Processing at the time, but no matter now.

This is my first experience with Linux, and it’s been a rocky ride. Arrow Electronics had a promotion for a free Pi with every $50 order, that was pretty cool. I’ve been trying to learn Arduino programming, and I like the idea of using the micro controllers with Processing on a little computer with a nice 7” touchscreen.

You can install it by yourself like @ddownn did but you can also download an Image of Rasbian with processing already included:

1 Like