Geomerative Library error

hi folks,
I got an error after I installed “Geomerative” library for run a robot based on Arduino Uno, how can I fix the problem? the error I got is as followed:
“more than one library is competing for this sketch” while I jusy installed Geomerative library once.

A geomerative library import is in conflict with other needed for your sketch.
Try to remove other library one by one and see if your sketch run.

1 Like


Try to run example sketch from the library examples note that on GitHub the library contains some files for two versions

all examples which are in Geomerative library examples run without ant problem, just I could not run my code :frowning:

in the address I installed processing, there is just one folder for library which consists of “Geomerative” library. no other library exists :frowning: I don’t know how can I fix the problem!

It doesn’t say more than one ‘Geomerative’ library. It could be that Geomerative adds another library that you already have.

Could you post the code that fails, including Arduino code if you want to use that as well? Did that error message come from Processing editor or Arduino editor?

(GitHub - DUCO2020/DUCO: a robotic system towards circuit fabrication on vertical surface)

I send its code in Github, could you please help me with that, I fix the problem regarding the conflict in libraries, but the processing file has some errors in the code since it composed of different files,I don’t know how can I fix it.

I fix the problem regarding the conflict in libraries

How did you do that?

When I try to run DucoGUI.pde I get the following error message:

The Geomerative library is required for RShape, so it appears that throwing away SVG Export (part of Processing) is your only option and I have no idea if that is even possible.

There is a fisica example called Letters which also uses this font and generates the same error message when trying to run it. However when the two apache font import calls are REMmed out it runs without error.

I tried remming out the font calls in both of the files found in Geomerative but the error message persisted. The only way I could get DucoGUI.pde to run was to leave out the Geomerative import, but then RShape is missing and there are other problems. I would be interested to know how you resolved the duplicate library problem.

I just change the version of processing software from 4.3 to 2.2.1
you can try it moreover I add 3 different libraries in processing called: geomerative, diewald_CV_kit, controlP5

no the problem I have now is that some parts of the codes are not defined well, I don’t know how c

an I fix the whole?

Hello @freesheida1984,

I got this error with Processing 4.3 on W10

It worked for me with Processing 3.5.4 on W10 as is:

The library is 3 years old so I used the version of Processing that I assumed it was developed on.

Libraries on Processing 3.5.4 that I have installed:


Sounds good, does the code comply without any error for you? although I installed all your libraries it gives me the following error:

what about Arduino code, does it run for you as well?

Only install the ones your require. ControlP5 and Geomerative are required from the import statements in your code.

Which version of ControlP5 are you using?

I always have a separate sketchbook folder for Processing 2, Processing 3 and Processing 4 to avoid any potential conflicts.

Example for P3:



much appreciated, it works now :slight_smile:
but I have the same problem with its Arduino code as well. is it needed to change the version of Arduino IDE I use, since this code was for 3 years before? at the moment I use version 1.8.10

1 Like

Either IDE should work.
You need to have the firmware and correct libraries installed.

See Tools > Manage libraries… in the either of the IDEs

This will take some effort on your part.

I just looked at the DucoFirmware.ino and it states:

*  the main file to run this firmware
*  Make sure you have correct hardware setup and wiring
*  then this firmware works reliably