G4P can´t continue with saved work


#1

Hello, I created a GUI with G4P tool, I saved it and after I opened it again I had the code in the GUI tab, but when I opened the G4P tool it overwrited the GUI tab to the default/blank template. How can I run the tool with the existing code?
Thank you for any help.


#2

Can you make a small runable example of your problem?


#3

I don´t know how could I make an example of this. The thing is that I saved my work in processing after using G4P tool. When I open it again, I can run the app and it´s working correctly. But when I want to edit the gui tab/code using G4P tool again (so after I open the tool again), it rewrites whole code (actually delete everything), so I can´t edit it. So I would like to know, if is it possible to continue with already made GUI with G4P tool.


#4

What versions of Processing, G4P and GUI Builder are you using?

The only time I have had this happen is when a user updates GUI Builder part way through creating the sketch.


#5

Processing 3.6 x64 and G4P gui builder 4.2.1. I just installed everything, created my app, saved, opened, and got this issue.


#6

Did you follow the instructions IN GUI tab comments.


#7

yes, I didn´t change anything in the gui tab. I just saved the work and now I would like to continue, using the G4P tool. For you guys it´s working correctly even after reopening the saved work?


#8

BEFORE you do anything else make sure you are using the latest software versions

  • Processing 3.4
  • G4P 4.1.5
  • GUI Builder 4.2.1

I don’t know where you got Processing 3.6 x64 from :thinking: did you mean 3.3.6?

Follow these instructions exactly:

  1. Launch Processing
  2. Start GUI Builder
  3. Add a button
  4. Save sketch as GUIBuilderTest
  5. Exit / close Processing

OK so next
6) Launch Processing
7) Open recent file GUIBuilderTest
8) Look in the GUI tab. Is there code for the button?
9) Run the sketch. Did the button appear?
10) Open GUI Builder does the button appear in the designer window?


#9

oh, sorry, you are right. I have version 3.4.

I did everything as you wrote and it´s working as it should be. But when I tried to save again my project to a different folder with different name, it´s still not working (the step 10, it´s blank).


#10

Did you use Processing menu option File > Save As or something else to copy the sketch?


#11

Save As. But I meant that I tried it with my “old” project. I think I will just create it again.


#12

Use Windows explorer to locate the sketch folder inside that you will find another folder called GUI_BUILDER_DATA look inside that folder and there should be a file ger.ser.?.? where ?.? represents part of the version number. What is it?


#13

the file name is gui.ser.4.2


#14

Was that for the ‘OLD’ project?


#15

Yes, if you want I can send you the code, or the files.


#16

I tried the steps I outlined above, including using File > Save as to change the folder and filename and still managed to used GUI Builder successfully afterwards.

There is only one reason why it might happen and that is if the original GUI was created with V4.1 or earlier version of GUI Builder.

If you have been using GUI Builder 4.2.1 throughout then there should be no problem.

Since I cannot reproduce the problem and no one else has reported the problem then there is nothing to be done about it.


#17

I understand. Thank you for your help anyway!