Exporting Application not working. "windres.exe: can't open file"

Hi all,
I’m trying to export a sketch to an application. I am using windows 10 and processing 3.5.3. I am trying to embed java when I export.
Regardless of the sketch I try I always get the same error:


I don’t understand most of it but at the top it says:

D:\processing-3.5.3\modes\java\application\launch4j\bin\windres.exe: can’t open file `cannot’: No such file or directory

I’ve checked and this file does exist.

Any help would be much appreciated. Thank you.

and? did you check if


is there? because i see it in my processing setup

if missing,
install processing again and check if windows defender deletes files.



you setup your sketch directory inside your processing installation??
hm, i never tried that, anyhow make a backup of your work first!

Hey thanks for the reply.
The file is there and I’ve already tried uninstalling and reinstalling.
I have all the same files as in that picture.

1 Like

ok here what i do just now ( win 7 / 64bit):

can you compare?
i just double click on the app under the application.windows64 folder

I have all settings in the Export Options the same but the only folder generated is “applicaion.windows32”
No application is made.

hm, because it breaks at try creating the windows32 app

  • did you try to do this with a other simple 5 line project?
  • can you give me your sketch?
  • can you move out your sketch dir to
    after you create that path and also changed it in preferences?

I’ve tried it with sketches of varying complexity and they’ve all come back with the same error.
I can’t give you the sketch as it has pictures of a friend (it’s for their birthday)
Just tried moving the sketch folder and that didn’t work either.

1 Like

what is the plan? you want to send that app ( 200MB ) by mail??
because just a idea,
download a new processing and unzip to USB stick
( if required win 32 / win 64 or even linux …too )
copy your sketch there too and try to run it on yours and other computers??

Well if I can’t get the export function to work then that is really my only other option.