Exported sketch is completely blocked from running

Hey y’all
I’ve got an app that I’m writing with the intention of sending it to other people to use.
When I export the program to run from a .exe (with JRE etc), when I send it to people for testing, and when I test it on another one of my computers, I initially get a warning saying windows defender has blocked it from running. However, once I allow it, the app completely doesn’t run. I’m talking no background processes, no hidden windows, nothing :frowning:

Needless to say, this is a major roadblock in development. And while I consider myself adequately tech-savvy, I cannot for the life of me figure out how to fix this.

Just so it’s clear:
The correct Java version is installed
I’ve disabled antivirus
It is running on the correct OS
Running app as admin

code is here if you’d like to take a look: https://github.com/nossonCotlar/Plaque

Any direction or suggestions are greatly appreciated

1 Like

far from that.

  • correct JAVA installed?
    i run processing ( what comes with JAVA )
    on WIN10 without any add installed JAVA
    so as you mention that i worry.
    what you do have to do is to enable export incl. JAVA
    and that you can also check by looking into the sub-dir
    /YOUR_APP/application.windows64/JAVA/
    ( so as i not see that in your picture i think you exported wrong [ ]JAVA option missing )

  • disabled antivirus might be a good test,
    but error looks more like windows defender
    so did you check on that?

  • assume you use WIN 10,
    but i am very new to that and far from calling it “correct OS”

possibly you mean you exported to [ ] windows
and try to start the windows 64bit ( sub-directory ) app?

  • run as admin
    on Linux it would mean like you used “sudo” to start a app
    ( allowing all privileges ) what did you do/enable?
    or you just want to say that you are admin but did not get a other window what asks
    if you want allow to run that app?

  • you give a link to your code, thanks, but first i do a
    test with a known sketch

    • open examples/basic/images/loadDisplayImage
    • save as ( under my working dir )
    • export (options:) Windows JAVA
    • select 64bit app and double click
      and my WIN 10 just run it. ( no questions asked )



but prior to testing with your code, a other question?
not only your wording is "unclear? also you not check what we can see in your picture.
but for me it does not look like the export directory!
did you copy the “wrong/JAVA missing” export to a ?USB? drive?
and try to start from there? ( running apps from USB is disabled? )

ok, just tested:
copy the 64.bit dir to a USB2 stick and run the app ( again no questions asked / strange )


so you ignore all you have tried and

  • run processing 3.5.3
  • select and " save as " a working example
  • export using windows and JAVA option
  • run the app

only that way we are sure that your environment is working

1 Like

I apologize, what I meant was that I would address some possible things people might suggest, and get into details if needed. I guess that’s happening now :slight_smile:

I have had the correct java version installed. I guess it was unclear from my post, but the exported program DOES run properly on my main computer, and on the computer of my friend, who I’ve sent the program to. It does not work, however, on a secondary computer of mine, and on my partner’s computer.

yes, I had disabled Windows Defender and same result.

We’re splitting hair at this point, but this is correct, both the computer used for exporting the program, and the computers running it, are all Windows 10 64 bit. This option was selected at the time of exportation as well.

Since it’s a windows program, it means I right clicked on the program and selected “run as administrator”

I’ve simply moved all the program files to another file. This works fine and always has. The name of the parent directory does not affect the program’s functionality.

I appreciate your time and help on this man, and while your wording sounds somewhat accusing, I know your’e trying to help so thank you <3

1 Like

Something to note, my program makes calls to websites that are not secured(http instead of https). Could this be causing issues? Again, the issues are NOT consistent between computers, which is making this a real pain in the rear.

ups, ok, now i understand, and why you do that?
as here it was not needed and i would never recommend that,
even my best friend write that code.


sorry, might sound like that, but it is just missing some
“exactness” in your error description.


hm, so you need to find out what is the difference in that computers.

anyhow looks like you not want to go with my tip
to use the JAVA export option
and test it there? ( i know the thing is then 190MB big )
i think it is the default way just to run it on any system
( so it does not matter IF or WHAT VERSION of JAVA is installed on the PC
as i mention already here i just use processing IDE )


so , do you require me to try to test it with your code here?

2 Likes

Just trying everything that might make a difference, I’m not quite sure what I was expecting lol

All good man I understand <3

I will try that next :slight_smile:

You don’t need to, it’ll probably be a pain lol, but if you have some time to waste it could help me. Up to you brother.

Just tried with embedding Java, and it seems to be working now :smile: sorry for wasting your time lol, your suggestion worked like a charm :ok_hand: thanks!

ok, some feedback
-1- i download the ZIP
unzip to my processing work dir

-2- i needed to rename the path from
/Plague-master/
to
/Plaque/

-3- i needed to install a lib

[HTTP Requests for Processing](https://github.com/runemadsen/HTTP-Requests-for-Processing) 0.1.4
[Rune Madsen](http://www.runemadsen.com), [Daniel Shiffman](http://shiffman.net)

HTTP Requests for Processing is a small library that takes the pain out of doing HTTP requests in Processing.

-4- it runs under WIN10 / processing 3.5.3
but show a error

/resources/parsha/Devarim/3.txt
The file "/resources/parsha/Devarim/3.txt" is missing or inaccessible, make sure the URL is valid or that the file has been added to your sketch and is readable.

on github you usually have a
main read-me where you give that kind of information
how to use your code…

-5- are that private family photos you use there?
! not recommended

-6- when i export and start the exported 64 app
i get a grey FULL screen, no pictures…
how to stop that? ok via task manager possible to stop the JAVA app. phuu…
( i stop the test here and delete all )

i can not recommend full screen apps, if a user want choose full-screen a window he can do later.
so yes there seems to be a problem code related? sorry, no idea

Right, the github branch name messed with processing IDE because it’s looking for the name of the main pde file.

That’s expected, I use http requests, not sure how to add the library to the source code itself but I’m sure it’s possible.

This isn’t a bug, its just that the program references files that I havent finished putting into the program yet. I’ll add those as I go (they change every day)

yeah I know lol, I should change that for privacy but for now I’m not too concerned. I’ll take them out in future commits

This is because when Processing exports the program, it doesnt include some necessary files and folder. To get it to work, you need to copy and paste the folder /resources/, as well as the files config.json and auth.json into the exported folder.
You can exit any Processing applet by pressing “Esc” on your keyboard :slight_smile: no need to go into task manager

In the completed program (exported for users) I include a get started guide :slight_smile:

1 Like