Runtime Library Installed, but not found? (Win10, Processing 4)

I am running Processing 4.0b1 on Win10x64.

When I “export application” and choose the “Embed Java” option, the .exe launches and runs fine.

However… When I “export application” and do NOT choose “Embed Java”, clicking the .exe file results in an error dialog saying “This application requires a Java Runtime Environment 11.0.11.” Closing that dialog opens a web page where Java runtimes can be downloaded.

I downloaded the current “OpenJDK 11” (11.0.12) from that web page and installed it. In the install options, I selected to have it added to my PATH. But still get the same issue – launching the exported Processing app says “This application requires a Java Runtime Environment 11.0.11.”

I uninstalled older versions of JDK. Still the same issue. Rebooted the machine, same problem.

At a command prompt, typing “java -version” says:

openjdk version “11.0.12” 2021-07-20
OpenJDK Runtime Environment Temurin-11.0.12+7 (build 11.0.12+7)
OpenJDK 64-Bit Server VM Temurin-11.0.12+7 (build 11.0.12+7, mixed mode)

…and “where java” says:

C:\Program Files\Eclipse Foundation\jdk-\bin\java.exe

…and the first item in my Path is:

C:\Program Files\Eclipse Foundation\jdk-\bin;

Also tried uninstalling 11.0.12 and installing the older 11.0.11 – thinking perhaps the message saying it required “11.0.11” meant what it said. No luck, still get the same error.

So I’m stumped. The exported Processing app says it needs the Java Runtime, but the Java Runtime is already installed. Tried all this on another Windows10x64 machine – same result.

What am I doing wrong? How do I get the processing app (exported without Java runtime) to use the Java Runtime already installed on Windows?


Possibly related issue:

1 Like

Could be related I guess… though the symptoms there are pretty different.

That report describes an application that starts and then fails with a Java runtime error. My exported app isn’t even starting – just the loader immediately reporting that it needs a Java Runtime – even though that Java Runtime is already installed and working for everything else.

There’s obviously some kind of “check” being done to determine if Java runtime 11.0.11 is installed before launching it, or perhaps the processing.exe stub tries to launch Java, check the version, and somehow fails. Either way, the exported Processing app is incorrectly concluding that the desired Java runtime is not installed, when it actually is. ¯_(ツ)_/¯

Perhaps open a different issue for it, since it seems separate? (unless you opened one already that I didn’t see).

Was hoping to see someone else confirm (i.e. having some problem) or deny (i.e. working fine for them) using Processing4 and Windows10. I’m new with Processing, so there’s always a chance I’m doing something wrong. I don’t want to bother developers with another github issue if my brain is the problem here, lol.

I guess I’m surprised nobody else has said “same thing happening here” or “nope, works fine for me”. On my test machines, any windows app exported from Processing4 (without embedded java) fails to run, saying the 11.0.11 runtime isn’t installed – when it actually is.

same problem here (Processing4 on MacOS 15 exporter / Windows 10 20H2 attempt to run, pop up requests JRE 11.0.11 and app won’t run even though 11.0.11 is already installed)