Error with semicolon translate in point


#1

Hi everyone,

I have a big problem with my Processing, when I tap a semicolon on my mac it appear a point in my code and same problem with double point it appear only a point. I already checked on other software to see if it’s my keyboard configuration, and I also redownload Processing but it sill donc work. Anyone have the solution for this problem ?

Thanks in advance!


#2

Uhm? Did you press Shift? That Makes the Point become a double Point and a comma a Semicolon. Else you might wanna Look into your configuration. You can find it under File (leftmost tab at the top) and then ‚options?‘ (sorry, on phone now…it’s almost at the bottom and has a pretty obvious name… maybe settings).


#3

No I didn’t press shift. Even if I copy paste a semicolon somewhere else it’s translate in point.


#4

Huh? Shouldn’t you press Shift to get a semicolon? Or is that different for mac? But that it converts a copied sign really is Strange… i mean you could copy any Type of character (Even really Strange ones) in there without Them changing…
Try to use the virtual keyboard. How to type OR on keyboard (mac)


#5

Actually it’s without shift on mac, but it’s really strange… I tried with the Keyboard Viewer it the same problem :confused:


#6

Ok then really Look at the options in the file tab. there you can set things like utf-8 charset. Maybe you changed that or have one that is not compatibile.


#7

I tried in the options and there is nothing wrong in this window, everything is checked


#8

Hi @Paco, does the code run, even though semicolons look like dots?

Could you please post a screenshot?

I would try to change the font and the font size in the options. I would also try to enable or disable DPI scaling.


#9

Hi @Jakub sadly no it don’t run, here a screen with the errors

(yeah it’is in french :upside_down_face:)


#10

Could you please copy the whole error which showed up in the console and paste it here?

Could you please try to download Processing 3.4 and run without the debugger?


#11

The error in the Sketch is only the result that the code couldn‘t be Compiled correctly, because the semicolon is a Point… Though it just doesn’t make sense that a pasted semicolon becomes a Point…


#12

@Lexyth However, that Array index out of range error, which is a runtime error, should not happen in this situation. Something is broken in the editor and I still want to see that stack trace from the console so I can fix it.

My theory is that what looks like a comma is actually a different unicode character. Could you @Paco please also save the sketch and upload it somewhere for me? That would help me a lot.


#13

Oh and also try to use semicolon in your Next Post and to copy paste the ‚point‘ in Processing to it. Maybe it translate to a completly different Char or not…

Edit: ok, i think i know why it‘s not working. The Problem is not, that comma doesn‘t become semicolon, the Problem is, that that is not Even a comma. If you Look where the error orriginates from, it seems like it is the comma in size, But if it was only the semicolon at the end that missed, the Problem Would be size in general, not just the comma from it. Maybe try choosing a different keyboard configuration.

And the arrayIndex out of Range could just be the result of size not loading properly.