Could not run sketch. Target VM failed to initialize

So since the release of the new windows 10 update and the release of the new nvidia drivers I could not use processing anymore because of the error in the title with EVERY kind of sketch (even empty ones).
I noticed that this error was common in 2017 as well when nvidia released a new driver and the solution there was to go back to previous graphic card drivers. I tried this option as well but it seems that the old drivers were not compatible with the new windows 10 update anymore so I was (and technically still am) kind of stuck.
I found a workaround, but I would like to know if someone has a solution for this problem.

My solution was to download the 32-bit Processing version even if my computer runs at 64.
So I just wanted to post this in case anyone has this problem and I would like to know if anyone has an actual solution for the 64 bit problem

thanks for this info ?warning not to update nvidia driver ?
can you add more details?


by any chance you could use the
[Roll Back Driver] ? option ?

I tried, but that option was greyed out for me. My guess is it was like that because of the windows new drivers system. Intel is going to update as well as you can read here https://www.intel.com/content/www/us/en/support/articles/000031572/programs/intel-corporation.html

Windows update 1903 fixed the error

1 Like