Cannot get processsing 3 core.jar to work with eclipse

Issue description
So I have tried for a couple of days to get processing 3 to work with eclipe without any luck. I have opened a thread on stackoverflow and i did not fully understand the answers i got there. Really thankful if anyone could help with this problem. The thing is that when i import the core.jar from processing 2, it all works , but not with processing 3 core.

Over att stackoverflow they where saying that i should put some jars into my classpath, is it the way to go?

You can see the errors on my tread over at stackoverflow.

URL(s) of affected page(s)
I have followed this tutorial :

this is my thread on stackoverflow:

This is another thread that suggest that i need to add some mac-specific jars??:

stackoverflow DOT COM/questions/50822590/using-eclipse-with-processing-cannot-get-java-application-to-run


You should use jdk8 to get processing to work on eclipse, with MacOS you may also need on your classpath to supply Mac specific stuff.



thanks for the answer, i did a reinstall of eclipse and jdk8 and it worked, thanks alot!!

Is it possible to have an explanation of exactly how to use jdk8 to get processing to work on eclipse? It’s not very clear how this can be done. The tutorial for eclipse appears to use macOS but doesn’t have this issue.