Can you run Processing on a Kindle?


#1

Is it possible to run Processing on a Kindle, and if so, how?


#2

Do you mean a Kindle e-reader, or a Kindle Fire?


#3

Its a Kindle fire, I seemed to be able to download Processing to it, but don’t know if it would actually work, or if it does, how to actually run it on this thing. :blush:


#4

I’m not really sure about Processing, but Processing uses Java to run, so if you can run Java on your Kindle Fire, you should be able to run Processing.

You can also use Javascript alternatives which work on any device, such as p5.js (Might take a bit of learning) or Processing.js (Can use the same code, but a bit out-dated) in your browser or a javascript IDE if there’s one on your Kindle Fire.


#5

Kindle Fire is basically an Android device isn’t it? So I’d look at the information about Processing on Android.

EDIT : just realised this is in the right topic :roll_eyes: was responding based on previous response rather than full context! Check https://android.processing.org And are you asking about running PDE or individual sketches?


#6

Processing runs fine on both my Kindle Fire 7, and Kindle Fire HD 10 (2017). It can run from APDE on the devices themselves, and from the PC.

You need to put them into Developer mode by going to Settings, to Device options, so you can see the Serial Number. tap that seven times and the Developer Mode becomes available. Setting those as on standard Android devices enables ADB on the PC thus allowing Processing for Windows to run it.

Example sketches work fine, but my own PulseBT sketch fails to install, and I get an error from the Ketai library I haven’t yet tracked down. Only tried this for myself a few days ago when my HD 10 arrived.


#7

Forgot to mention that in order to run APDE you need to install the Google Play store before you can download APDE or indeed any other Android app.

Use this link https://forum.xda-developers.com/amazon-fire/general/how-to-install-google-play-store-fire-t3486603


#8

Hmm, the Ketai error APDE reports during building is just a missing file called Ketai-Dex.jar referenced in an export list, but none of my other Android devices ever mention it, and they all use the same version of Ketai. It is only a warning, and doesn’t stop the sketch compiling. If I remove all references to Ketai and default the sketch to Demo mode which doesn’t need Bluetooth, it runs fine from APDE in both Kindles, and in Processing on the PC the demo version compiles fine but won’t install over ADB to either device.

But both devices seem to struggle to transfer large? files over the USB link, so I used a microSD card to copy both Ketai and the sketch files over for APDE to use and also copied the demo apk compiled on the PC.

The apk file installed and ran without issue on the Kindle 7.

The fully functioning apk compiled on the PC with Ketai still wouldn’t install or run even via the microSD card, so the Kindles definitely have an issue with Ketai.

[edit] My app is now running in full function mode with Bluetooth data. The first time I tried to install the full apk on the SD card it failed to install, but I decided to install it again. This time it worked. This is the apk compiled on the PC from the normal full sketch including Ketai. I don’t really know what changed, but the app now runs reliably.

This on the Fire HD 10. I will try it again on the 7.

[update] It works just as well on the Fire 7, too.