Android mode loadShape() is broken?

Hi, i run this simple code and works fine on windows, but only loads the first .obj model…
untitled.obj eject error when attempt to load a .mtl material file, i dont´k known the problem.

PShape s1,s2;
float ry;

public void setup() {
    size(640, 360, P3D);
    s1 = loadShape("3d/models/rocket/rocket.obj");
    s2 = loadShape("3d/models/cubo/untitled.obj");

public void draw() {

    translate(width/2, height/2 + 100, -200);

    ry += 0.02;


pls check if the .mtl file is existing ( at that android phone /path)

this project compiles perfect in java mode, and when i switch to android mode the same code not load the second object… the error is from loadShape() internally?

I dont´s wnown…

it´s necesary all files in same namefile?

@erkosone ===

are you sure that it loads the first object: as for me it does not and fires the same error: fileNotFound ex. which is absolutely normal using android mode…You have to use getAssets(), create file from its result and loadShape() after that, using absolutePath from getFilesDir().As your code is simply the basic one from examples “Shape”, only modifying the folders structure, begin with the example itself; after that you can complicate the thing! - i have tested in the 2 cases && it works, i can see some white&&blue rocket rotating…

loadShape works directly in android mode, at least with the latest version of android mode works without problems.
I do not know what you’re using, but I just load the rocket with loadShape ()

The model of the rocket does not use any external file, the robot’s if, the problem is the .mtl file, it is loaded erratically as the other partner comments.

@erkosone ===

  • You are right: i updated my android mode and now loadShape with the rocket works fine

  • But when i try to load the cube (with exactly the same folder structure:3d/…) it fires a fileNotFoundException for the .mtl

  • This exception disappears when i put the files at the first level of the data folder: that s why it worked with my code, copying these files before using loadShape(); anyway i can see nothing on the screen (perhaps because i dont know what coords to use with s2?)

  • I have tried also to put another .obj and .mtl about which i am sure that they are ok in the cubo folder, using the same code: fileNotFoundException

  • I have tried also to put rocket .obj and .mtl in the cubo folder, using the same code: it works!

-CONCLUSION=== ??? - Is it possible that the rocket.mtl has some specificity (weight???) - I dont know…