Android build failure

after I downloaded the new version of android mode for processing 4 wrote a simple program and when I tries to test it I got

Exception in thread "Thread-27" java.lang.NoSuchMethodError: 'java.lang.String, java.lang.String,, boolean)'

I then deleted all the code in the sketch and tried again and got the same error.

a brief look at the code seems to reveal that this method does not exists

Last I remember processing 4 is incompatible with android mode. You have to downgrade to processing 3.

1 Like


I am having the same issue

I issue was not produced when I downloaded the latest processing-4.0b8 with downloading Android Mode for Processing 4 (version 4.5.0 a4) and I’m able to run an Android Mode’s example Array code successfully on the device.

I need the following information @jSdCool @PoYo -

  • Processing4 version
  • OS on which you are using the processing4
  • Android Modes version (In windows you can check Android Mode version in C:\Users\User\Documents\Processing\modes\AndroidMode\ file. Check prettyVersion)
  • If you can provide the sample program which produces the issue, that would be helpful.
  • How did you test it? Did you use the play button to run the app on the device?