Text display has gone "Fuzzy"

Not sure how easy this is to replicate!

I’ve been working for weeks/months in Android Mode using fullScreen(P2D) as the renderer and just this last half hour, all text rendering has gone “fuzzy” - like on partial rendering is happening?! Nothing else, just the text.

If I comment out fullScreen(P2D); to use the default renderer everything looks great again but my frame rate take a massive hit - at least 4x slower!

Not sure what to try… anybody else seen this ever?

Does relaoding the sketch change anything. On some of my android sketches the camera is sometimes fuzzy until reload. But otherwise i cant help

@ paulgoux

Thanks for replying …

I’ve reset & reloaded everything, phone, laptop etc. It’s really weird!

What renderer do you use … ?

Always p2d on android

What does your sketch do. Might have a function causing issues.

Do all your sketches have this problem?


Yes p2d for me too … best frame rate by far!

The app does loads functionally (audio sequencer), but from a graphics viewpoint mostly just selectively displays rectangles, a few small images and text.

Some thing behind the scenes has broken somewhere for the text rendering … frustrating!


If I upload an apk would you see how it looks on your phone!?

Do you have the sketch instead?


Yes I do, but it’s 20455 lines of code, so far too big to post here!! And it’s in Android Studio now (for various reasons) so would need some work to get it back into P5.

I have found a solution for now though…

Up to now I have been using the default font as it seemed to work fine, but creating my own using createFont() and using that has fixed the fuzziness, and still gives me a similar/good frame rate. Phew!

There is something broken I guess when using the default font, but why it showed up just today after weeks and weeks of working I have no idea! So long as I have a fix though I’m happy to work with that!

Thanks for all your suggestions though … much appreciated.


Unfortunately im not going to be of much help as i have so little experience in android studio and tend to stick with the default processing pde.

Perhaps someone more knowledgeable can help.

In any case good luck with your project and yes id be keen to beta test.


Thanks … :+1:

There’s an app link on my website if you want to beta test :grin:

I remembered a similar thread, maybe it will help:

It’s for P3D, maybe it works for P2D on android as well? The solution was to set “textSize” to the largest text size in setup():
(textSize 128)

I’ve also encountered the issue that the font size (or possibly the kerning?) was a bit different between OS’es, unless set specifically with “textSize()”. I only tried it on Linux and Windows.

Hi thanks for your input. I’ll try that just to see what happens but using createFont has worked well … made a large one (32pt) similar to your code. Going to stick with it too as text rendering is much faster now!