"Target VM failed to initialize" with P2D & P3D

Hi there !
I suddenly have this message :

Could not run the sketch (Target VM failed to initialize).
For more information, read Help → Troubleshooting.

I wish it was more specific.
It happens only when I ask for P2D or P3D (both in static or dynamic mode), so it seems to be an OPENGL related issue.

After reading many previous forum contributions (like this one, specificaly related to P3D), I see it can be related to fonts, to my graphic driver, to librairies, but there it happens without doing anything (but I might have upgraded my graphic card driver though),… I really don’t have a clue and I’m not sure when I used P3D mode the last time.
I’m using Processing 4.2 on kubuntu, with a radeon graphics card…
If anyone has a clue, knows how to get a more specific error message, or has experienced the same problem recently on a similar system, I’m interested to know more !

1 Like

I did a lot of tryouts about my graphic card configuration, and at one point, kubuntu was unable to start at all, except with the shell. I tried a lot of other things, and eventually uninstalled “amdgpu”…
Now my system works apparently fine, and P2D/P3D works too !
I didn’t write down seriously each step, so I just can tell I ended up succeding.


you can mark the topic as “solved” :smiley: