surface.setResizable(false); doesn't work in the P2D renderer

I have been trying to use the built-in surface.setResizable function to disable the option to resize the processing sketch window in my sketches. However, when I attempt to use this method with the P2D renderer it does not remove the maximize button. I am on Windows 10 and using the latest version of processing. Below is an example that demonstrates my issue.

void settings() {

void setup() {
  colorMode(HSB, 10000, 10000, 10000);

void draw() {
  background(millis()%10000, 10000, 10000);

Hi @s31,

I don’t think it is possible to set resizable to false using P2D render.

There is another thread in the forum that might be helpful, but might not be the best solution