Sound on Android doesn't work

I tried the sound example ( and while the app “worked”, as in- it runs on the device, no sound is generated.

I get the Processing console error:
java.lang.NoClassDefFoundError: Failed resolution of: Landroid/media/AudioRecord$Builder;
at processing.sound.JSynAndroidAudioDeviceManager$AndroidAudioInputStream.start(Unknown Source)
at com.jsyn.engine.SynthesisEngine$ Source)
Caused by: java.lang.ClassNotFoundException: Didn’t find class “$Builder” on path: DexPathList[[zip file “/data/app/processing.test.musicnotes_06b_android-1/base.apk”],nativeLibraryDirectories=[/vendor/lib, /system/lib]]
at dalvik.system.BaseDexClassLoader.findClass(
at java.lang.ClassLoader.loadClass(
at java.lang.ClassLoader.loadClass(
… 2 more
Suppressed: java.lang.ClassNotFoundException:$Builder
at java.lang.Class.classForName(Native Method)
at java.lang.BootClassLoader.findClass(
at java.lang.BootClassLoader.loadClass(
at java.lang.ClassLoader.loadClass(
… 3 more
Caused by: java.lang.NoClassDefFoundError: Class not found using the boot class loader; no stack available

How do I solve it? What am I doing wrong?

Something to do with my installation?
I’m using Windows 10 & Processing 3.5.4
Tried on a Moto X (1st Gen) .and a Xioami Redmi 5A (Where I don’t ger the error report “AndroidDevice: cannot find process id, console output will be disabled”