Problem using VideoExport in Eclipse


#1

hello @hamoid! im trying to use your librarie in Eclipse… but the console show me this error:

java.lang.RuntimeException: java.lang.NoClassDefFoundError: com/sun/jna/platform/win32/Wincon

at processing.opengl.PSurfaceJOGL$2.run(PSurfaceJOGL.java:412)

at java.lang.Thread.run(Thread.java:748)

Caused by: java.lang.NoClassDefFoundError: com/sun/jna/platform/win32/Wincon

at Main.setup(Main.java:68)

at processing.core.PApplet.handleDraw(PApplet.java:2412)

at processing.opengl.PSurfaceJOGL$DrawListener.display(PSurfaceJOGL.java:859)

at jogamp.opengl.GLDrawableHelper.displayImpl(GLDrawableHelper.java:692)

at jogamp.opengl.GLDrawableHelper.display(GLDrawableHelper.java:674)

at jogamp.opengl.GLAutoDrawableBase$2.run(GLAutoDrawableBase.java:443)

at jogamp.opengl.GLDrawableHelper.invokeGLImpl(GLDrawableHelper.java:1293)

at jogamp.opengl.GLDrawableHelper.invokeGL(GLDrawableHelper.java:1147)

at com.jogamp.newt.opengl.GLWindow.display(GLWindow.java:759)

at com.jogamp.opengl.util.AWTAnimatorImpl.display(AWTAnimatorImpl.java:81)

at com.jogamp.opengl.util.AnimatorBase.display(AnimatorBase.java:452)

at com.jogamp.opengl.util.FPSAnimator$MainTask.run(FPSAnimator.java:178)

at java.util.TimerThread.mainLoop(Timer.java:555)

at java.util.TimerThread.run(Timer.java:505)

i can import the librarie correctly, but the error is in the line that i create the videoExport obj:

videoExport = new VideoExport(this);

im doing something wrong? i put the ffmpeg file into the folder also. its the basic sketch example, but in eclipse


#2

This should help: https://github.com/kfrajer/ProcessingVideoInEclipse

I don’t think you need to add ffmpeg to eclipse. You just need to make sure it is in your PATH variable. If you open a command prompt and type echo %PATH%, the path of the ffmpeg executable should be there in that output.

Kf


#3

Hi! Which OS, version, Processing version and Java version are you using?


#4

Java 8, El capitan, processing 3


#5

I’ll check out the code. Strange that it tries to access com/sun/jna/platform/win32/Wincon if you are on Mac.


#6

Try, but still not working.


#7

Could you please share your Main.java code? I tried in the Processing IDE in Mac and in IntelliJ Idea in Linux and it worked fine.