Problem installing a library (Chroma)

Can someone with more experience of contributed libraries please look at

I cannot install this library in Processing. I have tried to download and manually install into ~/Documents/Processing/libraries

But I can see the downloaded folder does not contain a .jar file or a library folder.

If i‘m not completely mistaken, i think the Chroma library should be part of the libraries you can directly install from within Processing.

I can only tell you how I imported the lib on my tablet, using APDE. ( I do not have a PC).
I used this link to download the zip, and it installed perfectly. I only changed the, " processing.core.PGraphicsRetina2D" renderer to P2D, in the example files. Everything seems to work properly.
Edit: If I remember well, you only need to unzip the files into the libraries folder, and the examples will automatically be shown in the the menu.


The download and installation worked perfectly, thank you.

But, changing the renderer does not work for me.

//size(1200, 1200, "processing.core.PGraphicsRetina2D");
size(1200, 1200, "P2D");

returns the error, “The P2D renderer is not in the class path.”. Do I need to put something somewhere?

no " "


but it also run here with only

1 Like

Well, that was easy :rofl:

1 Like

Sigh…, I have to complete 20 characters.

There are also problems with the use of variables in size() and using saveFrame() inside keyReleased() but they are easy to solve. Even I can do it.

i reported it for you :slight_smile:

Thank you! I added comments about size() and saveFrame().

That is not correct, unfortunately – Chroma has never been submitted to Contributions Manager and added to sources.conf, so it has to be manually installed.

1 Like