Please help! Processing is showing loadTable is not defined?

Want to import csv data in Processing but it is showing loadTable is not defined…


jQuery.Deferred exception: loadTable is not defined

ReferenceError: loadTable is not defined
at Processing.Processing.setup (eval at attach (, <anonymous>:15:4)
at executeSketch (
at new Processing.Processing (
at HTMLDocument.<anonymous> (
at l (
at c (


Uncaught ReferenceError: loadTable is not defined[Show stack](

Show your code/ link

float angle;

float lat = -37.8136;
float lon = 144.9631;

Table table;

void setup() {
	size(600, 600, P3D);
	table = loadTable("", "csv", "header");

void draw() {
	translate(width/2, height/2);
	angle += 0.05;
	float r = 200;
	for (TableRow row : table.rows()) {
		float lat = row.getFloat("latitude");
		float lon = row.getFloat("longitude");
		float mag = row.getFloat("mag");
		println(lat, lon, mag);
	float theta = radians(lat) + PI/2;
	float phi = radians(lon) + PI;
	float x = r * sin(theta) * cos(phi);
	float y = -r * sin(theta) * sin(phi);
	float z = r * cos(theta);
	translate(x, y, z);

@Chrisir I want to work with data visualization on the globe, and my work is very similar to mapping these earthquake data on the globe, but I cannot load any CSV file into it.


Try this:
table = loadTable("", "header");


Hi @glv I initially tried the same thing but still it is showing the same error.


Both of these work for me:

table = loadTable("", "header");

I downloaded and put in the sketch folder in /data:

table = loadTable("significant_day.csv", "header");

Try running this in Processing on the desktop.

You may not be able to access data from from a URL in OpenProcessing; I have not been able to last time I tried.


Hi @glv I am new with processing well I am using processing online editor maybe that’s why it’s not working for me.

Answered in last post… I updated it.

Then can you please tell me how to use it.

Processing can be downloaded from here:

There are also resources on the website to help you.


Thank you so much @glv for the help

1 Like

Loading resources from URL used to be fine and dandy, but nowadays, they are blocked by CORS (the headers at the server end).

Your code runs fine in the Desktop IDE.