No serial library Processing for smartphone. Help

android usb serial lib crashing app


December 2016 edited December 2016 in Android Mode

Hi all! Another day, another question - I am building an app that takes the content of sms and pushes it through to an arduino using the android usb serial lib here:

I am running the app on a pixel xl running nougat 7.1.1, and using the usb otg adapter to connect to an arduino uno. I have modified the manifest xml, and added in the device filter xml (ensuring that it includes the uno device id) but when I run the app it throws this error:

"Processing-Android USB Serial ERROR

Port: null Check the following items: 1. Make sure AndroidManifest.xml contains use-feature tag for 2. USB Serial is connected to the device"

I have checked that the manifest has the use-feature tag, and the usb cable is plugged in and supplying power to the arduino, but if I plug the cable in before starting the app, or plugging it in after the app has started, or even plugging it in before, then unplugging it when the error shows and replugging - it always throws the same error and closes when I close the dialogue.

I was wondering whether the android manifest requirements have changed since the release of nougat but that doesn’t seem to be the case. Does anyone have any ideas why this could be causing a problem?

1 Like