Having trouble running pde file from command line

Hi. I’m trying to get a pde file to run from command line (cygwin installed on windows). I have processing-java installed and I’m in the correct directory. My pde file is called genflag and I run the following

processing-java --sketch=`pwd`/genflag --run

but I always get the error:

\cygdrive\c\users\Karim\FlagsTBot\Flag_Bot\genflag does not exist.

does anyone know why this might be happening?
Can I not run it through cygwin?

Edit: I realize my pde file was named differently from the parent folder which isn’t allowed. I have fixed that but I’m still getting the same error.

hi, i can not help about the cygwin thing,
still i think that you first should confirm that processing-java works.

  • so when you say

I’m in the correct directory.

again, open a cmd window there?
check with dir
that you see
processing-java.exe (26.07.2018)
and type

processing-java --sketch=yourdrive:/../processing-3.4/modes/java/examples/Basics/Image/LoadDisplayImage --run

it works here / win 7 / but full install processing 3.4 IDE

1 Like

Thanks for your response. I did have processing.java installed. I actually ditched using cygwin and I figured out the correct command for using the windows terminal. The correct command was processing-java --sketch=%cd%/Flag_Bot --run when I wasn’t using the % around the cd before.