Font Install Issues

Good morning all. I see this topic has been posted before, and resolved to some extent.

I’m trying to add a font called “Conthrax”, however the Processing IDE will not load it. The
font works in other programs such as MS Word, or Photoshop, so I know Windows is detecting
it properly.

The Processing font list shows odd entries for many fonts. I’ve tried reverting back to an old
version, and updating to the latest version. I’ve tried listing the fonts using an array/list.

I’ve tried adding the font within the Font library of Processing folder, but no luck.

Any other ideas would be appreciated!

Hi,
not a really good answer but… i had a problem like that with a ttf properly installed on windows but not seen in processing, trying the same font file on mac solved the issue…
if you give a link for it, i can give a try.
Cheers

hi
you can add font file to your sketch i tried this with 7 segment font i add the file to the sketch it self and works

PFont Segment, Units; 

 void setup() {
                        
  size(480, 180);         
  Segment = createFont("Segment7", 150);  

Thank you both.

I used Jafal’s concept and it worked!

The .ttf had to be added to the path, but otherwise easily done.

Have a great night.