Does Export application work on the Raspberry PI

I want to be able to make an application that will work without installing Processing on the PI. I’ve tested this on a Windows installation and can make an application that will run on a windows machine without loading Processing. When I try this from within the Raspberry Pi environment I do not see an apllication that I can run.

Does this work on the PI.

1 Like

I just tried a simple program on my RasPi with Processing version 3.5.3 and it worked fine. It will produce several linux versions but the one you are interested in is /application.linux-armv6hf.


1 Like

OK, thanks I will retest.

Ok, I see all of the folders that are generated when I export, and I see the one that says “ARM”, but I do not see anything that looks like an executable. Can you point me to that? When I do it on a windows application it’s quite obvious what the executable is.

yes, the dir contains a executable file typ sh


starting java using … /lib/RPI_processing_export.jar

a auto start at boot

Start up export file with processing on raspberry pi 3 find here


The file in the folder is a startup script. Double Click it and see if you get a question to execute it. Just click Execute.


1 Like

Finally getting back to this after a break.
OK, I found there was an issue exporting a file which was loaded from a thumb drive. I did not create all of the files in the multiple directories when i exported.

If I move the file that I want to export into the sketchbook directory on the Pi and then export, All of the files are generated and I can run the bash file.

However, when I move the sketchbook folder that contains all of the exported files and try to execute on a clean build that does not have processing installed, it just hangs.

Am I missing something. I thought the idea of the export was to proved a complete package that you could give to someone who is not running processing.

Am I doing something wrong?
Have you tried it on a fresh Raspian build that does not have Processing installed.

Any help or suggestions would be appreciated.


yes, that is the idea,

but sorry, i did not test this on RASPBIAN

your description is a little bit poor to see that?

-a- can you try that with a original processing example what NOT use any library
-b- can you confirm that you for export click [linux] and [embed java]
-c- can you make sure that you use the linux way for transport, like .zip of .tar
just copy file to usb stick and copy back might not work with linux app files.
also run from USB drive does usually not work

1 Like


i export one of my templates
copy to PC
setup new RPI Buster and update
copy to new sketchbook unzip

so i tested to run a export on a RPI without processing


1 Like

I have tried with a fresh curl install of Processing on a current Raspberry Pi Stretch.
The examples are running well inside the processing GUI*, but when I export the examples (e.g.MixtureGrid), I get 4 folders and in the folder
the sh file upon a double click asks to execute or execute in terminal.
If you chose execute it will do nothing visible
If you chose execute in terminal it will open an error Failed to execute child process xterm (no such file or directory)

Additional info: I am running VNC.
Running within the IDE, the MixtureGrid example is displayed on the HDMI screen, but NOT on VNC, which shows only a black window.
The compiled MixtureGrid misbehaves identically if I control it from a Keyboard/mouse/Scrren or over VNC.

P.S. I compiled without the JAVA libraries since I have Oracle JAVA8 installed already.

1 Like

the above procedure and pictures are related to newest RASPBIAN Buster ( on a RPI 3B+ )
but this also worked on the older RASPBIAN stretch

did you click on [ EMBED JAVA for Linux 32bit ] ?

so with this i can not help you.
but somewhere is documentation how to use external installed JAVA from processing.

any reason why you just have to do that differently?

for VNC please use
options / troubleshooting / enable direct capture mode

still for most of the work i have that switched OFF


Thank you both works now!
I have assumed that having Java8 already installed could work, but I was wrong.

1 Like

So on

RPI4 Buster, open file browser, Edit-Preferences and turn on check box for Don’t ask options on launch executable. That stops the execute, execute in terminal non-sense.

1 Like

Thanks for your help. I got it working. It was the copy mechanism. When I used zip to transport the files it works.