Box2D library installation error

I have used Box2D examples from Nature of Code before. However, when I tried to run an example today, I got these errors:
No library found for shiffman.box2d
No library found for org.jbox2d.collision.shapes
No library found for org.jbox2d.common
No library found for org.jbox2d.dynamics
Libraries must be installed in a folder named ‘libraries’ inside the sketchbook folder (see the Preferences window).

So I tried to install Box2D from the Contributions Manager. I get the following error. How can I resolve the problem ? Thanks !!

Hi apac,

I had the same problem!

You need to do load it on github and manually install it.

Ok, thank you. I have already downloaded it from the link:

I created a folder called ‘libraries’ under my sketch folder. Not sure which of the files from box2d_processing downloaded folder should be placed directly under ‘libraries’ folder. I have tried to place the jar files under ‘libraries’ but that did not work (box2d_processing.jar, jbox2d-library-2.2.1-ds.jar). I have tried a few different hierarchies of files/folder. But still get the above error messages.

i just follow that link and see that the git files /lib/… are 5 years old,
what i did was follow the link in the readme
and after download, from there i unzip/copy dir /box2d_processing/ into the ( here existing ) subdir /libraries/
and ( after restart processing (3.4) ) then found examples that work, like

for the full path / where are the JAR files?
in processing3.4 | Files | preferences | find Sketchbook location like:
and after correct copy find

both files from 3.3.2014

Be careful apac, the place were you should put your library is not where your project is.

Sheck out this link:

jb4x, I solved the problem. I was correctly installing box2d under the ‘libraries’ folder of my sketch. I was opening the sketch program from windows explorer. I realised that I did not change the location in Preferences=>Sketchbook location. After I changed the Sketchbook location under Preferences to the correct folder, it worked !

Thanks for your help !

Thanks ! Problem is now solved.