# On Startup: "That's new to me - A strange and unexplainable error occurred"

**URL:** https://discourse.processing.org/t/on-startup-thats-new-to-me-a-strange-and-unexplainable-error-occurred/40899
**Category:** Processing for Pi
**Created:** [February 11, 2023, 11:47am UTC](https://discourse.processing.org/t/on-startup-thats-new-to-me-a-strange-and-unexplainable-error-occurred/40899 "2023-02-11T11:47:10Z")
**Posts on this page:** 1
**Showing post:** 3

<div class="post-metadata">

### Author: ![fabianluscher](https://yyz2.discourse-cdn.com/flex036/user_avatar/discourse.processing.org/fabianluscher/32/17959_2.png) [@fabianluscher](https://discourse.processing.org/u/fabianluscher)
#### Post date: [February 13, 2023, 10:04am UTC](https://discourse.processing.org/t/on-startup-thats-new-to-me-a-strange-and-unexplainable-error-occurred/40899/3 "2023-02-13T10:04:43Z")

</div>

Solved:  
Somehow, the owner / group ownership got (?) changed for the folder `/tmp/processing` where tmp files are created for running a sketch. The owner/group was “root / root” and i’m not sure what the initial value was.

If I change those to my current user with

```auto
$ sudo chgrp GROUPNAME /tmp/proccessing
$ sudo chown OWNERNAME /tmp/proccessing

```

It works again.  
Not sure how long though. and what I did that those ownerships got changed or what else might be amiss.

EDIT: calling “sudo …/processing-java --sketch=… --run” inside `home/USER/.config/lxsession/LXDE-pi/autostart` sets user/group of `/tmp/processing root/root` somehow

---

_[View the full topic](https://discourse.processing.org/t/on-startup-thats-new-to-me-a-strange-and-unexplainable-error-occurred/40899)._
